Haga que LinkedIn oauth2 llame desde localhost usando PHP

Estoy intentando hacer un complemento de LinkedIn que busque el perfil de los usuarios. Estoy usando REST API para ese propósito, pero cuando hago una llamada desde localhost muestra el siguiente error

Simple-LinkedIn: library not compatible with installed PECL OAuth extension. Please disable this extension to use the Simple-LinkedIn library.

por favor guíame.

archivo de índice

archivo oauth

En ambos archivos, solo se cambian los valores clave.

Estoy usando el servidor XAMPP en mi ventana 7 32 bit.

0

1 Respuestas

Realmente tienes dos opciones.

En primer lugar, puede seguir la sugerencia en el mensaje anterior y desinstalar el módulo oauth PECL que entra en conflicto con la biblioteca Simple-LinkedIn. Extenciones de PECL. Se puede desinstalar a través de:

pecl uninstall xxx

Donde xxx es el módulo.

En segundo lugar, puede usar el módulo oauth ya instalado para realizar llamadas a LinkedIn. Los detalles sobre cómo hacer llamadas usando esta biblioteca se pueden encontrar en el sitio de Desarrolladores de LinkedIn:

https://developer.linkedin.com/documents/reading-data#toggleview:id=php https://developer.linkedin.com/documents/writing-linkedin-apis#toggleview:id=php

0
agregado
PHP - Comunidad española
PHP - Comunidad española
9 de los participantes

Enlace para invitaciones: https://t.me/joinchat/B2gdShUFvCner-RgqRF43A En este grupo hablamos de PHP. Partner: es.switch-case.com