Modificando la versión ssl usando openssl en el servidor wamp

Actualmente estoy trabajando en probar algunas vulnerabilidades en TLS 1.0. Creé un sitio web y lo organicé en el servidor wamp 2.4. Estoy usando openssl para crear certificados autofirmados para la versión de cifrado SSL. 1.01. Pero la versión actual de openssl utiliza TLS 1.2. Quiero usar TLS 1.0 en lugar de probar algunas de las vulnerabilidades como el ataque BEAST presente en TLS 1.0. Me gustaría saber cómo puedo modificar la versión para que el sitio web ahora use el protocolo TLS 1.0.

0

1 Respuestas

Intente leer este manual :

Luego, en el \ wamp \ bin \ apache \ apachex.y.z \ conf \ extra \ httpd-ssl.conf encuentre esta línea

SSLProtocol all -SSLv2 

A continuación, cambie esa línea para incluir solo el protocolo que desea probar, de modo que sea el único que se use.

0
agregado