ESP8266 LED azul se mantiene permanece encendido

He encontrado una combustión similar a la mía, pero no hubo una buena respuesta.

He conectado mi ESP8266 a Arduino UNO.

Luego tuve algunos problemas con la comunicación serial del software con Arduino y decidí cambiar la velocidad en baudios a 9600 (anteriormente era 115200).

Usé el comando AT + IPR = 9600 para cambiarlo.

Después de eso, el led azul de esp permanece encendido y ya no toma los comandos AT, pero emite algo de galimatías al monitor en serie.

Nota: conecté el esp8266 a través de un regulador de voltaje y una fuente de alimentación y ambos dieron el mismo problema. Se supone que mi firmware debe actualizarse, así que no creo que sea el problema.

¿Podría alguien ayudarme por favor?

0
Has cambiado la velocidad de transmisión. Intente hacer coincidir la velocidad en baudios de su UNO con su nueva velocidad en baudios. Baudrates inigualables de hecho causarán galimatías. Tal vez el "firmware actualizado" sea realmente el problema, ya que el dispositivo no responde bien, intente volver a actualizar el firmware (cuando sepa qué velocidad en baudios es).
agregado el autor dotnetengineer, fuente

1 Respuestas

¿Cambiaste el firmware? Creo que la velocidad en baudios solo se puede cambiar si se actualiza con la versión más reciente del firmware.

0
agregado
Como lo mencionó Paul, ¿ha intentado volver a cargar el firmware? Descubrí que Nodemcu Flasher es la forma más fácil de cargar el firmware. Cree también una configuración sencilla de parpadeo como éste . Vale la pena hacer si planeas usar ESP8266.
agregado el autor Vince Panuccio, fuente
Sí, he cambiado el firmware. El problema es que al intentar volver a cambiar la velocidad en baudios no está aceptando ningún comando AT, aunque lo intenté con diferentes velocidades en baudios.
agregado el autor KeithS, fuente