Problemas con la instalación de Visual Studio Express

Acabo de instalar 'Visual C# 2008 Express Edition' y 'Visual Web Developer 2008 Express Edition' en mi máquina Vista. Anteriormente he estado ejecutando estos en Win XP. Cuando lanzo el software, empiezo un nuevo proyecto y trato de construirlo, recibo advertencias como "No se pudo encontrar el 'Sistema' del componente al que se hace referencia."; una fila para cada espacio de nombres utilizado. Tengo .NET Framework 3.5 instalado y puedo navegar por las pestañas en 'Agregar referencia', pero no puedo hacerlo funcionar. (Una reinstalación no ayudó.) ¿Hay una solución fácil?

0
agregado editado
Puntos de vista: 1
¿Lo está ejecutando como administrador? (Haga clic derecho en el menú contextual en el exe)
agregado el autor Thomas Wagner, fuente

4 Respuestas

¿Estás iniciando a través de "Ejecutar como administrador"? Es posible que los permisos en sus directorios .Net framework no sean lo que deberían ser.

0
agregado

Realmente no quería seguir la respuesta aceptada y hacer una instalación limpia. Una mejor solución que obtuve de los foros de MSDN:

Go to Control Panel > Programs and Features > Turn Windows Features on or off...

Then enable everything under Microsoft .Net Framework 3.0

0
agregado

Problema resuelto. Usé la solución más radical que pude encontrar: una instalación limpia de Vista. De alguna manera, la reinstalación de Visual Studio no incluye todos los pasos esenciales. La primera vez que se lanza el software, se configura a sí mismo. Algo debe haber salido mal la primera vez y cuando se volvió a realizar el procedimiento, se intentó usar la configuración "rota". Bueno, ahora está arreglado.

0
agregado

¿Tiene algún parche o actualización que pueda haber para ese software? El otro pensamiento sería copiar System.dll en la carpeta bin del proyecto, que es lo que solía hacer en proyectos anteriores para que todo funcione.

0
agregado